Monday, May 2, 2022

How To replace faulty ethernet adapter Which is part of shared ethernet on AIX VIO, without reconfiguring SEA

 Replace faulty ethernet adapter Which is part of shared ethernet on AIX VIO, without reconfiguring SEA.

Lets see....

Scenario:

on VIO server version 2.2 one of the 4 port ethernet adapter is faulty and it caused ,SEA in error state.

we provided snap to IBM CE from VIO and IBM confirmed that ethernet adapter is faulty it needs to be replaced.

So following steps IBM recommended:


Steps 1:

Take all prechecks for VIO like ,latest mksysb, viosbr and all necessary health check

step2 :

Make sure that AIX admin have faulty ethernet adapter location details:

lsslot -c pci // Display all Hot hot-plug slots in the system unit.

example 

ent0  10/100 Base-TX Ethernet PCI Adapter  // port 1

ent1 10/100 Base-TX Ethernet PCI Adapter  //// port 2

ent2  10/100 Base-TX Ethernet PCI Adapter // port 3

ent3  10/100 Base-TX Ethernet PCI Adapter // port 4


if admin do #lscfg -vpl ent0 

#lscfg -vpl ent0 // show location of faulty ethernet adapter


step 3:

once location identified and IBM CE in data center ,identify that faulty ethernet adapter using "diag" utility.


#diag-->press enter-->task selection-->hot plug task-->PCI hot plug task-->identify PCI hot plug slot--->select and set to identify mode .


once CE confirm this , admin exit from this window


step4:

failover all SEA to secondary VIO and shutdown VIO

for i in `lsdev -Cc adapter | grep -i shared |awk '{print $1}'`
do
echo "-------shared SEA $i  failover to partner VIO------ "
chdev -l $i -a ha_mode=standby
echo "---------------------"
sleep 2
done

step 5:

Ask IBM CE to replace faulty ethernet adapter

once ethernet adapter is replaced ,activate VIO and do health check.

step 6:

check ethernet adapter is available .then do SEA failback.

for i in `lsdev -Cc adapter | grep -i shared |awk '{print $1}'`
do
echo "-------shared SEA $i  failover to partner VIO------ "
chdev -l $i -a ha_mode=auto
echo "---------------------"
sleep 2
done

check SEA link, by following script

for i in `lsdev -Cc adapter | grep -i shared |awk '{print $1}'`
do
echo "-------shared SEA $i  state priority and active status ------ "
entstat -d $i | grep -i link
echo "---------------------"
sleep 2
done

This way we can replace faulty ethernet adapter . 


Thanks

:)






No comments:

Post a Comment