Monday, December 5, 2022
Boot AIX lpar from single user mode to multiuser
LDAP user authentication issue on AIX LDAP client
- Check whether NFS mounted LDAP mount point is mounted and healthy state . From this nfs mount point user home directory is accessible.
- Make sure that slapd -server daemon and secldapclntd - Client Daemon active on LDAP server and LDAP client.
- Also make sure that there is no CPU and memory bottleneck on this server.
Sunday, December 4, 2022
Resource group switch and online and offline on AIX VCS cluster
Saturday, December 3, 2022
AIX HACMP script to monitor cluster resource group health
How to access LPAR from HMC console
Add Alias IP address to AIX server ethernet interface using chdev command
Hello All,
Today topic is Alias IP configuration on ethernet interface.
Scenario 1:
Alias IP configuration on en0 using chdev with permanent/temporary.
Command for assigning alias IP on en0 interface permanently is like following.
#chdev -l en0 -a alias4=192.168.0.100,255.255.255.0
This will add IP address 192.168.0.100 as Alias IP to en0 interface. AIX admin can verify this using command
#ifconfig -a
Chdev command permanently set IP to interface en0. this alias IP address remain on AIX interface after reboot also.
Let's consider scenario where AIX admin wanted to set IP address for temporary purpose, he can use following command
#ifconfig en0 192.168.1.3 netmask 255.255.255.0 alias
Scenario 2:
If AIX admin wanted to remove that alias IP, how he can remove that??
Answer:
Remove a permanently added alias from an interface
chdev -l en0 -a
delalias4=192.168.1.3,255.255.255.0
Another useful command for adding default route on AIX server
#route add default 192.168.1.1
Here I am sharing small script to check whether AIX server ethernet interface are pingable or not
============================================================
for i in `ifconfig -a |grep -i inet |awk '{print $2}'`
do
echo $i
ping -c 10 $i
done
Above script will ping to IP address assigned to interface, if they up and active will get ping response.
Friday, December 2, 2022
Execute AIX mksysb in background with nohup utility
Hello All,
Today i am writing this blog to show how AIX Admin can Execute AIX mksysb backup using "nohup" utility and monitor logs using tail command.
AIX Mksysb
This method is usefull to get logs of AIX mksysb backup command
#nohup mksysb -ieX /backup/Aixlpar.mksysb &
Above command will generate 1 process id and run this command in background, also create nohup.out file,where all logs for above command will logged. If above mksysb backup command fails,AIX admin can review nohup.out file and take correct action to solve issue.
Command to monitor logs in "nohup.out" // nohup.out will genrate in same path from where AIX admin executed mksysb command.
#tail -f nohup.out
Some other useful command for taking AIX server mksysb backup are :
Create a mksysb backup of the rootvg volume group
#mksysb -i /mnt/Aixlpar.mksysb.`hostname`_`date +%m%d%y`
Above command will create backup with servername and time,date and year format.
Thanks !!!
:)